Banner cycler

Fejl på ACC ng900

Forum for alt der drejer sig om de sidste nye modeller fra fabrikken. Saab NG900, 9-3, 9-5 og 9-3SS

Redaktør: Bestyrelsen

Brugeravatar
Jensen
Administrator
Indlæg: 6349
Tilmeldt: 5. okt 2004, 20:57

Fejl på ACC ng900

27. okt 2018, 10:56

Jeg var ved at rode lidt med min gamle ng900 med ACC og fandt ud af kabineblæseren ikke kører. Klimapanelet lyser fint op og alle funktioner ser ud til at virke, men ingen "blæst" uanset om der er skruet helt op til max.
Jeg har kontrolleret sikring nr 3 som forsyner blæseren med strøm og denne er OK. Der er også fint 12v over tænding til sikringen.
Systemet er lidt mere kompliceret da bilen ombygget til benzinfyr som kan styre blæseren. Fyret er dog afmonteret men ledningsnettet sidder der stadigvæk. Første indskydelse var at der var heri fejlen lå, så jeg fjernede akvariedækslet for at få adgang til blæseren direkte.

Men efter at have bypasset den del af ledningsnettet ved at sætte de originale ledninger direkte på blæseren virker det stadig ikke. Jeg kan heller ikke måle nogen spænding på den originale orange ledning der skulle forsyne blæseren med strøm. Så forbindelsen er brudt et sted mellem sikringen og + ledningen til blæseren.

Et kig på ledningsdiagrammet gør mig heller ikke klogere. Ifølge WIS burde der være +12v over tænding (klemme 54) på den orange ledning. Blæserhastigheden styres så ved at den brune ledning går til en "transistorblok" der laver modstand på stelsiden, kontrolleret af klimapanelet.
Men ifølge monteringsanvisningen til benzinfyret sker denne styring på plussiden og den brune ledning til blæseren går direkte på stel.
Her er et udsnit af diagrammet fra WIS:
Ng900 ACC ledningsdiagram WIS.JPG
Og her er diagrammet fra monteringsanvisningen til benzinfyret:
Ng900 ACC ledningsdiagram BenzFyr.JPG
Den nederste indeholder både diagrammet for ACC og MCC, og i en bil med MCC er det meget sandsynligt at modstandene til hastighed for blæsermotoren sidder på + siden. Uanset hvordan der er opbygget har det fungeret fint indtil jeg opdagede fejlen her i går.

Men hvilket af diagrammerne er korrekt?

Som kan ses er der i nederste diagram tilføjet et relæ der kan give strøm til blæseren når motoren er slukket. Dette relæ har jeg også kontrolleret og der er fint gennemgang mellem klemme 87a og 30 når der er afmonteret.

Hvis der er fejl i WIS er det sandsynligvis "transistorblokken" i ACC styringen er er defekt. Har nogen erfaring med denne :?:

Ifølge WIS sidder denne bag handskerummet, men jeg synes ikke lige jeg kan finde den. Jeg synes det ville være mere logisk at al styringen sad indeni klimapanelet. Jeg har dog desværre ikke et andet klimapanel jeg lige kan teste med.

Jeg har også prøvet at luse 87 og 30 for at give 12v direkte til blæsermotoren uden at dette giver noget. Dette underbygger at hastigheden styres på + siden og at der er en defekt i styringen der forhindrer at spændingen kommer videre.

MVH Mads


Mads Jensen, medlemnr. 143
'03 OG9³ jubi ('97 NG900SE 2,5 V6 -> AOG)
4Roger
SUPER SAAB FREAK
Indlæg: 170
Tilmeldt: 17. okt 2016, 01:12

Re: Fejl på ACC ng900

27. okt 2018, 11:47

Hej Mads,

Du har sikkert ret i mistanken:
https://shop.speedparts.se/sv/prod/900- ... 58272.html

Prøv ar google på udenby'sk, feks: saab 900 Blower Motor final stage Resistor
Link: https://www.google.dk/search?client=ope ... AJs1JAtP8I
eller
saab 900 Blower Motor Resistor Controller

Masser af oplysninger, videoer og reservedele

Mvh. Allan
Brugeravatar
Jensen
Administrator
Indlæg: 6349
Tilmeldt: 5. okt 2004, 20:57

Re: Fejl på ACC ng900

27. okt 2018, 13:44

Hej Allan og tak for svar.
Så vidt jeg lige kan google (og se i EPC) sidder modstandsblokken kun på biler med MCC. ACC har jo næsten trinløs hastighedsregulering hvor MCC har 4 faste trin. Så jeg er bange for at der ikke er denne modstand jeg har brug for. Men ellers et godt bud. Det er vist meget normalt at de står af.
Jeg tror jeg vil prøve at adskille mit klimapanel og kigge efter dårlige lodninger med en lup. Det er jo over 20 år gammel elektronik vi har med at gøre her.
I stikket H8-1 bør jeg også kunne måle om der er gennemgang/modstand/strøm hvis stikket er tilgængeligt uden at splitte hele kabinen ad. Det burde kunne opklare om det er på plus- eller minus-siden styringen sidder.

MVH Mads
Mads Jensen, medlemnr. 143
'03 OG9³ jubi ('97 NG900SE 2,5 V6 -> AOG)
Brugeravatar
Jensen
Administrator
Indlæg: 6349
Tilmeldt: 5. okt 2004, 20:57

Re: Fejl på ACC ng900

27. okt 2018, 14:45

Super, det var lige det jeg ledte efter :D
Jeg vender tilbage.
MVH Mads
Mads Jensen, medlemnr. 143
'03 OG9³ jubi ('97 NG900SE 2,5 V6 -> AOG)
Brugeravatar
Jensen
Administrator
Indlæg: 6349
Tilmeldt: 5. okt 2004, 20:57

Re: Fejl på ACC ng900

27. okt 2018, 15:23

Så fik jeg kalorius frigjort
137504F8-ABA7-4DAC-B9CF-EBD97C8F3979.jpeg
Den er forsynet med to skruer hvilket måske betyder at den kan adskilles. Det må prøves.

For øvrigt kører blæseren hvis klemme 7 i stikket forbindes til stel, så blæseren er helt sikkert stelstyret som angivet i WIS.
Mvh Mads
Mads Jensen, medlemnr. 143
'03 OG9³ jubi ('97 NG900SE 2,5 V6 -> AOG)
Brugeravatar
Jensen
Administrator
Indlæg: 6349
Tilmeldt: 5. okt 2004, 20:57

Re: Fejl på ACC ng900

27. okt 2018, 15:55

Den kunne adskilles og indeholder en mosfet.
image.jpg
Nu må se om den kan omloddes eller om jeg skal skaffe en ny mosfet.
Mvh Mads
Mads Jensen, medlemnr. 143
'03 OG9³ jubi ('97 NG900SE 2,5 V6 -> AOG)
Brugeravatar
Mortenvig
SUPER ULTRA EXTREME SAAB FREAK
Indlæg: 917
Tilmeldt: 10. aug 2016, 17:53

Re: Fejl på ACC ng900

27. okt 2018, 16:09

Wis har det rigtige diagram.
Varmer monterings vejledningen. er stærkt fortegnet, når det gælder Acc systemet.
Selve styremodulet er relativt enkelt, det består af en transistor NPN der sender en variabel spænding videre til motoren.
0 volt fra panelet motor slukket 5 volt fra panelet fuld knald på liggehønen.

Og det er meget normalt modulet brænder af, det har jeg oplevet på mange forskellige bilmærker.
Slet ingen kølepasta på pladen?
Hvis man kan finde nummeret på transistoren, så burde man kunne finde en erstatning.

MVH
Morten
9-3 2,0 t 2003 170 hk nu med 200 hk AERO klon motor.
Projekt tråd.
viewtopic.php?f=4&t=32002
Tidligere Biler
Volvo 245 turbo 250+ hk
Volvo 264 turbo 250+ hk
Volvo 242 dl 90 hk
BMW 2002 150+ hk
Brugeravatar
Jensen
Administrator
Indlæg: 6349
Tilmeldt: 5. okt 2004, 20:57

Re: Fejl på ACC ng900

27. okt 2018, 18:42

Her er transistoren afmonteret:
mosfetBlæserstyringNg900.jpg
Og jo der var masser af 20+ år gammel kølepasta både udvendigt og indvendigt og det var rigeligt fedtet, så ingen problemer her.
Men Made in Sweden har nok alligevel sine begrænsninger.Der er heller ikke meget luftudskiftning på den placering den sidder.

Sære ting sker med bilen når denne enhed er afmonteret:
Klimapanel er sort hvilket er forståeligt nok.
Belysning i speedometer er på max og kan ikke reguleres, men i SID reguleres det fint :?
D.T.E. i SID virker ikke, men de andre funktioner ser ikke ud til at være påvirket...

Det er ikke sikkert at enheden styrer noget af det ovennævnte, men måske får nogle andre enheder stel/strøm gennem denne.
Det ville være et mareridt at fejlsøge hvis en af disse funktioner holdt op med at virke og at det var en defekt i blæserstyringen der var årsagen...
Jeg har nu efterloddet men har ikke de store forhåbninger.
Her fandt jeg en ny dims som jeg vil bestille: https://el-supply.dk/?Vnr=30IRFP054
MVH Mads
Mads Jensen, medlemnr. 143
'03 OG9³ jubi ('97 NG900SE 2,5 V6 -> AOG)
Brugeravatar
Jensen
Administrator
Indlæg: 6349
Tilmeldt: 5. okt 2004, 20:57

Re: Fejl på ACC ng900

1. nov 2018, 16:47

Lige en opfølgning på problemet.
2B89B31A-0C66-4A61-B25D-9DB41EB34804.jpeg
Ny mosfet loddet i, og der er igen blæst i systemet.
Tak for hjælpen til alle.
MVH Mads
Mads Jensen, medlemnr. 143
'03 OG9³ jubi ('97 NG900SE 2,5 V6 -> AOG)
Brugeravatar
Viggen
Bestyrelsen
Indlæg: 636
Tilmeldt: 8. sep 2006, 09:12

Re: Fejl på ACC ng900

1. nov 2018, 18:48

Til lykke Mads. :D

Det ser ud til, at du også kan ordne tænder. :wink: Se annoncen. :idea: :shock:

Venlig hilsen Ole
SAAB 9-3 Aero 2,8T SportCombi Hirsch+


SAAB 9-5 Aero Estate (solgt)
SAAB 9-3 Viggen Lutfisk + extra (solgt)
Brugeravatar
Jensen
Administrator
Indlæg: 6349
Tilmeldt: 5. okt 2004, 20:57

Re: Fejl på ACC ng900

2. nov 2018, 07:10

Ja Ole det kan jeg også fikse.
Jeg har en akkuboremaskine samt en udmærket loddekolbe og noget loddetin med 50% bly. Bare send tænderne til mig i en boblekuvert, så er de fikset i løbet af en uge :lol:
MVH Mads
Mads Jensen, medlemnr. 143
'03 OG9³ jubi ('97 NG900SE 2,5 V6 -> AOG)

Tilbage til "Modern Forum"